Accueil > Comprendre, Agir > Informatique, ordinateurs > Je n’aime pas les serveurs mutualisés !

Je n’aime pas les serveurs mutualisés !

mardi 30 juillet 2013

J’ai rencontré Philippe aux 10 ans des faucheurs. Je l’ai entendu dire qu’il avait un problème avec son site : L’hébergeur le poussait à passer à php5 mais la version de SPIP qu’il utilisait ne fonctionait qu’avec php4. Je lui ai proposé un coup de main.

Une brève vérification m’a permis de constater que le SPIP de ce site était la version 1.9. La solution m’a semblé claire : il suffisait de mettre SPIP à jour. L’ennui est que le serveur, hébergé chez 1and1.fr est un serveur mutualisé. "Mutualisé" est un mot qui sonne positivement à nos oreilles, en général.

Un serveur mutualisé, c’est un serveur qui héberge plusieurs sites, appartenant à des personnes différentes. L’hébergeur ne laisse donc aucune de ces personnes être root sur le serveur (avoir le contrôle du serveur) : les risques d’une mauvaise manoeuvre mettant hors-ligne tous les sites concernés seraient trop grands.

Oh, on a tout de même des fichiers httpd.conf et .htaccess, mais les directives générales données au serveur priment sur ce qu’on écrit dedans...

Une mise à jour d’un programme non fourni par l’hébergeur, tel que SPIP chez 1and1.fr, doit donc se faire manuellement. Et quand ça cafouille, les possibilités d’intervention sont limitées.

Passer de spip 1.9 à spip 2.0 a échoué. Passer directement à spip 3.0.10 (la version stable actuelle), aussi. Passer de spip 1.9 à spip 2.0.10 (version stable) a été une vraie galère : un site bancal, sans aucune mise-en-page, des 404 partout... spip 2.0.10 n’est pas prévu pour s’installer dans un sous-répertoire... 3 jours de boulot avant d’obtenir un site suffisament stable pour pouvoir faire la mise à jour vers la version 3.0.10, qui, elle, fonctionne correctement dans un sous-répertoire.

Si j’avais été root sur ce serveur, j’aurais eu 2 lignes de texte à écrire pour faire cette mise à jour et vérifier/régler au passage les éventuels problèmes de compatibilité entre les version de php et les versions de spip...

Ne vous laissez pas avoir par le vocabulaire. "Mutualisé" n’est pas synonyme de "bon", tout comme "naturel" n’est pas synonyme de "bon". Les amanites phalloïdes aussi, c’est naturel... Un serveur mutualisé, c’est comme une grosse amanite phalloïde : vaut mieux garder ses distances.


Si vous trouvez que ce post ne fait pas sérieux au milieu de tous les beaux articles, vous pouvez le virer :).

Un message, un commentaire ?

Forum sur abonnement

Pour participer à ce forum, vous devez vous enregistrer au préalable. Merci d'indiquer ci-dessous l'identifiant personnel qui vous a été fourni. Si vous n'êtes pas enregistré, vous devez vous inscrire.

Connexions'inscriremot de passe oublié ?